Service Degradation Affecting Zoom Contact Center in Europe region

Incident Report for Zoom

Resolved

This incident has been resolved and the affected services have been restored.
Posted Apr 27, 2026 - 05:14 PDT

Monitoring

On 04/27/2026, Between 10:58 AM UTC to 11:23 AM UTC, Users may have experienced issues with Zoom Contact Center in Europe region

This incident has been resolved and the affected services have been restored.
Posted Apr 27, 2026 - 04:45 PDT
This incident affected: Zoom CX - EMEA (Zoom Contact Center).