Service Degradation Affecting Zoom Services in Canada.

Incident Report for Zoom

Resolved

This incident has been resolved and the affected services have been restored.
Posted Apr 28, 2026 - 00:21 PDT

Monitoring

On April 28, between 04:50 UTC - 05:37 UTC Users might have experienced issue using Zoom services in Canada. The issue has been successfully resolved. Our team will continue to monitor the situation closely and keep you informed of any further developments.
Posted Apr 27, 2026 - 23:08 PDT
This incident affected: Zoom Meetings (Zoom Meetings), Zoom Phone - NORTH AMERICA (Zoom Phone), and Zoom Clips, Zoom Docs, Zoom Tasks.