A subset of users are experiencing delay and issue with joining Zoom Meetings, Rooms, Webinars, Live Streaming, Contact Center's Video Engagement.

Incident Report for Zoom

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 06:29 PST

Monitoring

We have resolved the issue causing a subset of users experiencing delay and issue with joining Zoom Meetings, Rooms, Webinars, Live Streaming, Contact Center's Video Engagement. We have been monitoring the situation for several hours. We will continue to provide updates as we have them.
Posted Nov 19, 2025 - 01:43 PST

Update

We have identified the issue causing a subset of users experiencing delay and issue with joining Zoom Meetings, Rooms, Webinars, Live Streaming, Contact Center's Video Engagement. We will provide updates as we have them.
Posted Nov 19, 2025 - 00:59 PST

Identified

We have identified the issue causing a subset of users experiencing delay and issue with joining Zoom Meetings, Rooms, Webinars, Live Streaming. We will provide updates as we have them.
Posted Nov 19, 2025 - 00:21 PST

Update

We are continuing to investigate a subset of users experiencing delay and issue with joining Zoom Meetings, Rooms, Webinars, Live Streaming. We will provide updates as we have them.
Posted Nov 18, 2025 - 23:21 PST

Update

We are continuing to investigate a subset of users experiencing delay and issue with joining Zoom Meetings, Rooms, Webinars, Live Streaming. We will provide updates as we have them.
Posted Nov 18, 2025 - 22:20 PST

Update

We are continuing to investigate a subset of users experiencing delay and issue with joining Zoom Meetings, Rooms, Webinars, Live Streaming. We will provide updates as we have them.
Posted Nov 18, 2025 - 20:42 PST

Update

We are continuing to investigate a subset of users experiencing delay and issue with joining Zoom Meetings, Rooms and Webinars. We will provide updates as we have them.
Posted Nov 18, 2025 - 19:43 PST

Investigating

A subset of users are experiencing delay and issue with joining Zoom Meetings. We are currently investigating and will provide updates as we have them.
Posted Nov 18, 2025 - 18:56 PST
This incident affected: Zoom Meetings (Zoom Meetings, Live Streaming, Zoom Webinars), Zoom Rooms (Zoom Rooms), and Zoom CX - Global (Video Engagement).