We will be performing scheduled maintenance to upgrade our Push Notification Service.
No operational impact is expected. This maintenance includes the following enhancements and improvements:
- Added available alert migration and capability-gated delivery enhancements, including the new client capability flag and migrated available-alert handling across presence and login flows.
- Added inbox expired-entry cleanup sync and zset-size observation/trimming controls, improving inbox consistency across peers and providing better operational visibility for oversized inbox keys.
- Added group session cache support for group publish delivery, reducing repeated session lookups and improving scalability for large group notifications.
- Refactored the WebSocket event-handling architecture, removing the old protocol module, splitting logic into dedicated event-handling components, and introducing non-blocking ACK tracking for better maintainability and delivery reliability.
- Added Push Global Event enhancements, including a dedicated AsyncMQ consume path for global events and connection-side periodic delivery for eligible WebSocket clients.
- Added batch-by-batch UCS lookup support for OID queries, improving stability and performance when handling large UCS group lookups.
- Fixed pub request observability and diagnostics gaps by enhancing access-log output, adding tagged request logging, improving PII-safe logging behavior, and logging requests with missing name or category.
- Fixed RPC behavior in the pub path by enabling keepalive to improve connection reuse and reduce RPC overhead.
- Fixed read-suggestion retrieval logic by introducing a rolling 30-day window so only recent suggestions are considered during fetch.
- Fixed global event delivery behavior by tightening the periodic-push flow, ensuring only eligible authenticated sessions start the background delivery thread, and keeping a single active delivery trigger when periodic push is enabled.
- Fixed WebSocket unregister handling semantics by removing obsolete close-frame unregister logic and clarifying that device cache cleanup is driven by the client unregister flow.
All services are expected to operate normally during the maintenance window.
Posted Apr 28, 2026 - 23:32 PDT
This scheduled maintenance affects: Zoom Meetings (Zoom Meetings, Zoom Conference Room Connector, Zoom Webinars), Zoom Chat (Zoom Chat), Zoom Website (Zoom Dashboard & Reporting, Web Portal, Web Client, Integrations/Calendar/Plug-In/Add-In), Zoom Rooms (Zoom Rooms), Zoom Virtual Agent - Global (Zoom Virtual Agent), Zoom Mail (Calendar, Mail), Zoom CX - Global (Zoom Contact Center), Zoom Developer Platform (Marketplace), Zoom Phone - Global (Zoom Phone), and Zoom Events.