Issues Affecting Zoom Phone Outbound Calls in EU region

Incident Report for Zoom

Resolved

This incident has been resolved.
Posted Nov 20, 2025 - 15:06 PST

Monitoring

Our underlying carrier partner has fixed the issue where a subset of users were experiencing intermittent issues with outbound calls using Zoom Phone. Our team will continue to monitor the situation closely and keep you informed of any further developments.
Posted Nov 20, 2025 - 08:27 PST

Investigating

We observed service degradation again where a subset of users are experiencing intermittent issues with outbound calls using Zoom Phone. We will provide an update as soon as more information becomes available.
We appreciate your patience as we work to resolve this issue.
Posted Nov 20, 2025 - 07:33 PST

Monitoring

Our underlying carrier partner has fixed the issue where a subset of users were experiencing intermittent issues with outbound calls using Zoom Phone. Our team will continue to monitor the situation closely and keep you informed of any further developments.
Posted Nov 20, 2025 - 05:52 PST

Update

We continue to work with our carrier partner to resolve the issue where a subset of users are experiencing intermittent issues with outbound calls using Zoom Phone, and we will keep you informed with timely updates as progress is made. Thank you for your patience.
Posted Nov 20, 2025 - 05:17 PST

Update

We continue to work with our carrier partner to resolve the issue where a subset of users are experiencing intermittent issues with outbound calls using Zoom Phone, and we will keep you informed with timely updates as progress is made. Thank you for your patience.
Posted Nov 20, 2025 - 04:17 PST

Identified

We have identified the issue with our underlying carrier in Europe region where a subset of users are experiencing intermittent issues with outbound calls using Zoom Phone.
We are actively working with our carrier partner to resolve the issue, and we will keep you informed with timely updates as progress is made. Thank you for your patience.
Posted Nov 20, 2025 - 03:17 PST

Investigating

We are currently investigating a service degradation with Zoom Phone outbound calls in Europe region.
Our team is actively working to identify the impact and root cause. We will provide an update as soon as more information becomes available.

We appreciate your patience as we work to resolve this issue.
Posted Nov 20, 2025 - 03:00 PST
This incident affected: Zoom Phone - EMEA (Calling (Inbound/Outbound)).