Service Degradation with Notes, Tasks and Whiteboard in the Saudi Arabia Region

Incident Report for Zoom

Resolved

This incident has been resolved and the affected services have been restored.
Posted Dec 22, 2025 - 11:28 PST

Monitoring

On 12/22/2025 between 18:10 UTC to 18:32 UTC - A subset of users experienced issues with Notes, Tasks and Whiteboard Service Degradation in Saudi Arabia Region. Our engineers have mitigated the issue and this incident has been resolved.
Posted Dec 22, 2025 - 11:17 PST
This incident affected: Zoom Notes, Zoom Tasks and Zoom Meetings (Zoom Whiteboard).