We have resolved the incident where a subset of users experienced issues with Sign in, Join using 3rd party Integrations and Zoom Meetings in Europe region particularly detected on Amsterdam and Frankfurt. Zoom will continue to monitor and provide updates as soon as there is more information to share.
Posted Oct 29, 2025 - 05:49 PDT
Update
We continue to investigate the impact and root cause. Zoom will provide updates as soon as there is more information to share.
Posted Oct 29, 2025 - 05:30 PDT
Update
We continue to investigate the impact and root cause. Zoom will provide updates as soon as there is more information to share.
Posted Oct 29, 2025 - 05:27 PDT
Update
We are continuing to investigate this issue. We've also noticed that the subset of users might not be able to join Zoom Meetings using 3rd party integration.
Posted Oct 29, 2025 - 05:16 PDT
Investigating
We have detected service degradation where a subset of users may experience issues with Sign in and Zoom Meetings in Europe region particularly detected on Amsterdam and Frankfurt at this point. Our engineers are currently investigating the impact and root cause. Zoom will provide updates as soon as there is more information to share.
Posted Oct 29, 2025 - 05:10 PDT
This incident affected: Zoom Meetings (Zoom Meetings, Zoom AIC) and Zoom Website (Web Portal, Web Client, Integrations/Calendar/Plug-In/Add-In).