A subset of users may experience issues with our underlying carrier in Europe.

Incident Report for Zoom

Update

Our underlying carrier continues working to resolve the issue. We will provide updates as they become available.
Posted Aug 27, 2025 - 12:52 PDT

Update

Our underlying carrier continues working to resolve the issue. We will provide updates as they become available.
Posted Aug 25, 2025 - 12:51 PDT

Update

Our underlying carrier continues working to resolve the issue. We will provide updates as they become available.
Posted Aug 25, 2025 - 01:43 PDT

Update

Our underlying carrier continues working to resolve the issue. We will provide updates as they become available.
Posted Aug 24, 2025 - 01:43 PDT

Update

Our underlying carrier continues working to resolve the issue. We will provide updates as they become available.
Posted Aug 23, 2025 - 01:43 PDT

Update

Our underlying carrier continues working to resolve the issue. We will provide updates as they become available.
Posted Aug 22, 2025 - 12:47 PDT

Update

Our underlying carrier continues working to resolve the issue. We will provide updates as they become available.
Posted Aug 22, 2025 - 00:48 PDT

Update

Our underlying carrier continues working to resolve the issue. We will provide updates as they become available.
Posted Aug 21, 2025 - 13:08 PDT

Update

Our underlying carrier continues working to resolve the issue. We will provide updates as they become available.
Posted Aug 21, 2025 - 00:44 PDT

Update

Our underlying carrier continues working to resolve the issue. We will provide updates as they become available.
Posted Aug 20, 2025 - 13:01 PDT

Update

Our underlying carrier continues working to resolve the issue. We will provide updates as they become available.
Posted Aug 20, 2025 - 00:54 PDT

Update

Our underlying carrier continues working to resolve the issue. We will provide updates as they become available.
Posted Aug 19, 2025 - 12:51 PDT

Update

Our underlying carrier continues working to resolve the issue. We will provide updates as they become available.
Posted Aug 19, 2025 - 00:44 PDT

Update

Our underlying carrier continues working to resolve the issue. We will provide updates as they become available.
Posted Aug 18, 2025 - 12:44 PDT

Update

Our underlying carrier continues working to resolve the issue. We will provide updates as they become available.
Posted Aug 18, 2025 - 00:30 PDT

Update

Our underlying carrier continues working to resolve the issue. We will provide updates as they become available.
Posted Aug 17, 2025 - 12:31 PDT

Update

Our underlying carrier continues working to resolve the issue. We will provide updates as they become available.
Posted Aug 17, 2025 - 00:53 PDT

Update

Our underlying carrier continues working to resolve the issue. We will provide updates as they become available.
Posted Aug 16, 2025 - 12:30 PDT

Update

Our underlying carrier continues working to resolve the issue. We will provide updates as they become available.
Posted Aug 16, 2025 - 00:03 PDT

Update

Our underlying carrier continues working to resolve the issue. We will provide updates as they become available.
Posted Aug 15, 2025 - 11:58 PDT

Update

Our underlying carrier continues working to resolve the issue. We will provide updates as they become available.
Posted Aug 15, 2025 - 04:54 PDT

Update

Our underlying carrier continues working to resolve the issue. We will provide updates as they become available.
Posted Aug 14, 2025 - 22:43 PDT

Update

Our underlying carrier continues working to resolve the issue. We will provide updates as they become available.
Posted Aug 14, 2025 - 16:43 PDT

Identified

Our underlying carrier has identified the issue and is working to restore the API service. We will provide updates as they become available.
Posted Aug 14, 2025 - 10:31 PDT

Investigating

A subset of users(ZP/ZCC) may experience issues with delays in acquiring or porting telephone numbers, and updating associated address information in EU Region. We are actively working with our carrier partner to resolve the issue. We will share the updates as soon as we have them.
Posted Aug 14, 2025 - 08:32 PDT
This incident affects: Zoom Phone - EMEA (Zoom Phone) and Zoom CX - EMEA (Zoom Contact Center).