Service Degradation Affecting Zoom Phone, Zoom Contact Center and Zoom Meetings in Europe

Incident Report for Zoom

Update

The issue affecting Zoom Phone, Zoom Contact Center and Zoom Meetings has been resolved.

Our team will continue to monitor the situation closely with the Vendor and keep you informed of any further developments.
Posted Sep 10, 2026 - 09:29 PDT

Update

We are continuing to monitor for any further issues.
Posted Sep 10, 2026 - 09:06 PDT

Update

We are continuing to monitor for any further issues.
Posted Sep 10, 2026 - 08:57 PDT

Monitoring

On 09/10/2026, Between 14:58 UTC to 15:02 UTC, Subset of users may have experienced issues with Zoom Phone and Zoom Contact Center in Europe.
This incident has been resolved and the affected services have been restored.
Posted Sep 10, 2026 - 08:53 PDT
This incident affects: Zoom Meetings (Zoom Meetings, Meeting Dial-in/Telephony), Zoom Phone - EMEA (Zoom Phone), and Zoom CX - EMEA (Zoom Contact Center).