A subset of users might have experienced audio issues on PSTN calls for Zoom Phone and Zoom Contact Center in Europe region.

Incident Report for Zoom

Resolved

This incident has been resolved.
Posted Nov 25, 2025 - 21:19 PST

Monitoring

Between 11/25/2025 18:00 UTC and 11/26/2025 04:48 UTC, a subset of users might have experienced audio issues on PSTN calls for Zoom Phone and Zoom Contact Center in Europe region. This incident has been resolved and the affected services have been restored.

Our team will continue to monitor the situation closely and keep you informed of any further developments.
Posted Nov 25, 2025 - 21:07 PST
This incident affected: Zoom Phone - EMEA (Calling (Inbound/Outbound)) and Zoom CX - EMEA (Voice (Inbound/Outbound)).