Zoom Contact Center Service Degradation in the North America Region

Incident Report for Zoom

Resolved

This incident has been resolved.
Posted Feb 25, 2026 - 11:19 PST

Monitoring

On 2/25/2026 between 18:15 UTC to 18:35 UTC Zoom Contact Center experienced call drops in the North America region. The issue has been resolved and will continue to monitor.

Our team will continue to monitor the situation closely and keep you informed of any further developments.
Posted Feb 25, 2026 - 11:09 PST
This incident affected: Zoom CX - NORTH AMERICA (Voice (Inbound/Outbound)).