Issue with accessing the webpages of Zoom website.

Incident Report for Zoom

Resolved

This incident has been resolved.
Posted Nov 20, 2025 - 00:17 PST

Monitoring

We have resolved the issue causing users to be unable to access the webpages of Zoom website. We will continue to monitor and provide updates as we have them.
Posted Nov 19, 2025 - 23:58 PST

Identified

We have identified the issue causing users to experience issue with accessing the webpages of Zoom website. We will continue to provide updates as we have them.
Posted Nov 19, 2025 - 23:43 PST

Investigating

Users will experience issue with accessing the webpages of Zoom website. We are currently investigating and will provide updates as we have them.
Posted Nov 19, 2025 - 23:36 PST
This incident affected: Zoom Website (Zoom Website).