Issues with Zoom Clips and Surveys in Singapore region.

Incident Report for Zoom

Resolved

This incident has been resolved.
Posted Nov 21, 2025 - 20:20 PST

Monitoring

On 11/22/2025, between 3:24 UTC to 3:58 UTC, users may have experienced issues with Zoom Clips and Surveys in Singapore region. This incident has been resolved and the affected services have been restored.
Posted Nov 21, 2025 - 20:12 PST
This incident affected: Zoom Clips and Zoom Survey.